Mi compilation de Xcode requiere cURL 8.0.0 o posterior (que no existe)

Estoy escribiendo un progtwig C en Xcode que usa cURL. Se basa correctamente en mi Mac Pro que ejecuta 10.8.5, pero en mi MacBook Pro que ejecuta 10.8.5, me da este error cuando bash comstackr:

dyld: Library not loaded: /usr/local/opt/curl/lib/libcurl.4.dylib Referenced from: /Users/AlecZ/Library/Developer/Xcode/DerivedData/UPServer2-folctfcnmdhllzbddscwimqrggig/Build/Products/Debug/UPServer2 Reason: Incompatible library version: UPServer2 requires version 8.0.0 or later, but libcurl.4.dylib provides version 7.0.0 

El último cURL es 7.37.0, por lo que no veo cómo podría requerir 8.0.0. Me he encontrado con problemas similares antes al intentar comstackr software para Linux desde su origen, el comstackdor indica que necesito una versión inexistente de alguna biblioteca.

Ya he ejecutado brew install libcurl , pero dice que no puedo replace la biblioteca del sistema por cURL.

Intente curl instalar el package curl , por ejemplo

 brew update brew reinstall curl libcurl 

Esto debería arreglar las dependencies rotas.

Si esto no ayuda, intente comentar o eliminar las DYLD_LIBRARY_PATH , DYLD_FALLBACK_LIBRARY_PATH o DYLD_FRAMEWORK_PATH de las secuencias de commands del shell de inicio (por ejemplo, ~/.bash_profile ).

Probablemente esta no sea la mejor solución, pero recordé esto justo cuando hacía la pregunta. Después de ejecutar brew install libcurl , moví todo excepto pkgconfig desde /usr/local/Cellar/curl/7.37.0/lib a /usr/lib , reemplazando files viejos. Así que todavía estoy en la versión 7.37.0, pero se comstack correctamente ahora. No sé qué intentaba decir el error del comstackdor.