Advertencia de Homebrew: "No hay herramientas de desarrollador instaladas" aunque Xcode está instalado

Después de instalar Homebrew, el command "brew doctor" regresa:

Warning: No developer tools installed. You should install the Command Line Tools. Run `xcode-select --install` to install them. 

… y tengo Xcode instalado.

De todos modos, después de ejecutar xcode-select --install aparece el instalador de Xcode, luego hago clic en "instalar" y el instalador se cierra.

¿Esto es normal? … y tengo que instalar Git de Homebrew, o puedo usar el que viene con Xcode?

Sí, es perfectamente normal que homebrew le solicite que instale Xcode. Eso me pasó justo después de instalar Mavericks.

En cuanto a su pregunta sobre git, depende mucho de su uso. El valor pnetworkingeterminado de git (y casi todas las demás herramientas) no son de la última versión. Si estás de acuerdo con eso, entonces por supuesto puedes usar el pnetworkingeterminado.

Xcode en sí mismo no es lo que necesitaba instalar, era específicamente las "Herramientas de command-line de Xcode", aparentemente eso es algo diferente …

Si tiene Xcode instalado, esta advertencia también aparecerá aunque make y gc sean proporcionados con éxito por Xcode. En este caso, puedes ignorar esta advertencia.