¿Qué versión de OpenGL es la correcta?

Quiero instalar cierto software y esto requiere un sistema que soporte al less OpenGL 2.1. Ejecutando glxinfo | grep "OpenGL Version" glxinfo | grep "OpenGL Version" devuelve la OpenGL version string: 2.1 INTEL-10.24.45 . Por otro lado, de acuerdo con la documentation de Apple: https://support.apple.com/en-us/HT202823 mi laptop, que es una Macbook Pro de 13 pulgadas, 2016, dos puertos Thunderbolt 3, tiene OpenGL 4.1 instalado. ¿En cuál debería confiar?