Problemas con /usr/lib/libcups.2.dylib. las aplicaciones x86 no se ejecutarán

Actualicé CUPS de 2.0.0 a 2.0.2 en OS X 10.10.4 Yosemite por razones de security según el asesoramiento de un escaneo de Nessus. Cometí el pecado capital de no hacer una copy de security de mi sistema operativo antes de hacer este cambio. Desafortunadamente, muchas aplicaciones x86 en mi sistema ahora muestran este error fatal:

Tipo de exception: EXC_BREAKPOINT (SIGTRAP) Códigos de exception:
0x0000000000000002, 0x0000000000000000

Información específica de la aplicación: dyld: launch, cargando bibliotecas dependientes

Mensaje de error Dyld: Biblioteca no cargada: /usr/lib/libcups.2.dylib
Remitido desde: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore Motivo: no se ha encontrado una image adecuada. Encontré: /usr/lib/libcups.2.dylib: mach-o, pero la architecture incorrecta /usr/lib/libcups.2.dylib: mach-o, pero la architecture incorrecta

Lo suficientemente justo. Así que decidí ejecutar lipo -info en la biblioteca afectada, y dice que su architecture es x86_64 ("Archivo no graso: /usr/lib/libcups.2.dylib es architecture: x86_64"). Deduje que la fuente de CUPS necesitaba banderas x86 (i386) en la configuration después de investigar un poco sobre el asunto. Entonces cuando ejecuté un nuevo command de configuration:

sudo ./configure CFLAGS="-arch i386 -arch x86_64" CXXFLAGS="-arch i386 -arch x86_64" LDFLAGS="-arch i386 -arch x86_64" 

Lo cual estuvo muy bien, pero se ejecutó con errores. Continué de todos modos con mis commands make y make install de buena fe, pero descubrí que ahora las aplicaciones afectadas no iniciaban o aún devolvían errores fatales. ¿Qué estoy haciendo mal aquí? Descargué la fuente directamente de CUPS.org si alguien se pregunta.

Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).