Instalar versiones anteriores de Java en OSX 10.8.1

Tengo una MacBook Pro Retina, ejecutando 10.8.1 y Java 1.6.0_35

Necesito instalar algunas versiones anteriores de Java para rastrear algunos errores que mis clientes están viendo en versiones anteriores de Java.

Traté de encontrar instaladores para versiones anteriores de Java de Apple Developer Network, pero ninguno de ellos se instalará en Mountain Lion.

¿Dónde puedo encontrar instaladores para versiones anteriores de Java? Específicamente, 1.6.0_07 y 1.5.0_xx que se ejecutará en OSX Mountain Lion?

Simplemente no puedes get versiones arbitrarias de Java para Mac. Apple proporciona sus propios binarys de Java y no proporciona todas las versiones de Java. Además, esas versiones antiguas tienen problemas de security conocidos con exploits activos en la naturaleza, por lo que es peligroso usarlos en un sistema de escritorio.

Mi mejor recomendación sería crear una máquina virtual Linux utilizando VMware Fusion e instalar las versiones anteriores desde el instalador del package Linux o utilizando packages descargados de Oracle.