Homebrew rompe con gcc obsoleto después de la installation de Lion OSX

 ➤ brew doctor

 / Desarrollador / usr / bin / gcc
 / Desarrollador / usr / bin / gcc
 Su versión de gcc 4.2.x es anterior a la versión recomendada.  Puede ser aconsejable
 para actualizar a la última versión de Xcode.

 No pudimos detectar gcc 4.0.x.  Algunas fórmulas requieren este comstackdor.

 $ GREP_OPTIONS se configuró en "--color = auto".
 Tener $ GREP_OPTIONS configurado puede hacer que las comstackciones de CMake fallen.

Xcode 4.1 está instalado, gcc -v:

 ➤ gcc -v

 Usando las especificaciones incorporadas.
 Objetivo: i686-apple-darwin10
 Configurado con: / var / tmp / gcc / gcc-5664 ~ 89 / src / configure --disable-checking - habilitable-werror --prefix = / usr --mandir = / share / man --enable-languages ​​= c , objc, c ++, obj-c ++ --program-transform-name = / ^ [cg] [^ .-] * $ / s / $ / - 4.2 / --with-slibdir = / usr / lib --build = i686-apple-darwin10 --program-prefix = i686-apple-darwin10- --host = x86_64-apple-darwin10 --target = i686-apple-darwin10 --with-gxx-include-dir = / include / c ++ / 4.2.1
 Modelo de hilo: posix
 gcc versión 4.2.1 (Apple Inc. compilation 5664)

¿Algúna idea de cómo arreglar esto?

  • No hay Boot Camp en High Sierra?
  • Apple Throttling IPhones (batería) - Detalles técnicos
  • Aplicación de dictionary constantemente descargando dictionarys
  • Mostrar events del calendar como text, en la terminal
  • Reemploop para aislador
  • Necesito ayuda con mac mail
  • Time Machine no hará una copy de security con Mountain Lion Server
  • Presentación de pantalla múltiple Keynote
  • 2 Solutions collect form web for “Homebrew rompe con gcc obsoleto después de la installation de Lion OSX”

    Hasta que se resuelvan todos los problemas, querrá seguir los problemas de 10.7 y Xcode 4.x en https://github.com/mxcl/homebrew/issues

    En este caso, asegúrese de administrar activamente su variable $ PATH para mantener sus versiones preferidas de aplicaciones networkingundantes primero en la expansión.

    La encoding de routes completas siempre es tediosa, pero la falta de ella causa estos baches cuando nuevos binarys aparecen inesperadamente en su path.

    Solo una corazonada, ¿ejecutó el instalador xcode? Al instalar xcode desde App Store, solo instala un instalador xcode. Debe ejecutar el instalador para instalar xcode.

    Solo pregunto porque no es exactamente obvio.

    El gcc pnetworkingeterminado ahora usa LLVM. La salida de gcc debería verse más o less así:

     gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00) 
    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).