Cómo ajustar el comstackdor para c ++ 11 en 10.8

Originalmente, publiqué mi pregunta sobre Stack Overflow. Comstackr el package R Parece que cuando instalo la biblioteca R (Boom) siempre obtengo el error relacionado con el error de compilation:

error fatal: el file "futuro" no encontrado incluye 1 error generado

Así que pensé que esa podría ser la solución, donde Michael sugiere cambiar el comstackdor simplemente diciendo "al comstackdor usarlo usando -stdlib = libc ++ y decirle al linker que se vincule contra él usando -lc ++". Fuente: Blog

De alguna manera estoy perdido en eso y realmente no puedo implementarlo. ¿Puedo pedir algo de ayuda?

También probé eso:

wget https://raw.githubusercontent.com/zeromq/cppzmq/master/zmq.hpp

mv zmq.hpp /usr/local/include/

Estoy usando Mac OSX 10.8.5 con Xcode versión: 5.1.0, Apple LLVM versión 5.1 (clang-503.0.40) (basado en LLVM 3.4svn) Objetivo: x86_64-apple-darwin12.6.0.

Aquí está el enlace al package Boom, una biblioteca C ++ para modelado bayesiano.

Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).